Degraded performance when opening projects

Incident Report for Framer

Resolved

The fix for the issue has been rolled out and everything is back to full function.
Posted Jul 28, 2025 - 19:00 CEST

Identified

Due to an issue that is overloading our storage layer, fetching projects might fail or be slower than usual. We have identified the root cause and we are working on a solution
Posted Jul 28, 2025 - 18:32 CEST
This incident affected: App.