Degraded performance when opening projects

Incident Report for Framer

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 20:27 CEST

Update

We are continuing to work on a fix for this issue.
Posted Jul 29, 2025 - 20:26 CEST

Identified

We are rolling out additional fixes, but the performance of the app is still degraded when opening large projects.
Posted Jul 29, 2025 - 17:48 CEST

Monitoring

Things are operational again, we are monitoring the situation as we release more safeguards.
Posted Jul 29, 2025 - 16:32 CEST

Identified

We've identified the issue and we are implementing a fix.
Posted Jul 29, 2025 - 16:18 CEST

Investigating

Due to an issue that is overloading our storage layer, fetching projects might fail or be slower than usual. We are investigating the root cause.
Posted Jul 29, 2025 - 15:47 CEST
This incident affected: App.